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Cadence Tutorial

Long Kong
1.1: Tool-setup
1.2: Starting up Cadence 6
1.3: Build a differential pair

Tutorial 1.1: Tool-setup
Go to SEASnet website:

http://www.seasnet.ucla.edu/UnixServers/eeapps

Follow instructions and install MobaXterm.
Once installed:
1. Start > All Programs > MobaXterm
2. Type the following to connect to eeapps:
ssh —X your_user_name@eeapps.seas.ucla.edu

3. Type your password when it asks for it.

Download tool.zip from CCL website:

http://www.seas.ucla.edu/brweb/teaching.html

Unzip it and there are three files: 215a.scs, cds.lib and tool-setup

Create ee215a directory in your home directory:

EE215A


http://www.seasnet.ucla.edu/UnixServers/eeapps
http://www.seas.ucla.edu/brweb/teaching.html
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mkdir ee2l5a <-- create ee2lba directory
cd ee2l5a <-- go to ee2l5a
pwd <-- find the current path

Type the current path at the top left window in MobaXterm, drag in 215a.scs, cds.lib and tool-setup to the
ee215a folder, now it looks like this:

Terminal  Sessions Tools Games

5 O B 4 % E @ B B8 X O X ©

Session  Servers Tools Games  Sessions View Split MultiExec Tunneling  Settings Help X server Exit

i3 i3

Name

=] 2158508
=l eds.lib
| tool-setup

a.edu” to login for L ncing
18

55H and Xming
s/eeapps.html !!

|Gﬁ-mtp| Macros || & Tools | X Sessions Ay

UNREGISTERED VERSION - Please support MobaXterm by subscribing to the professi i b mobatek.net

Tutorial 1.2: Starting up Cadence 6
At this point you should have completed the setup and be ready to invoke Cadence 6.

Cadence tool is invoked by typing the following at the command prompt:

csh

source tool-setup

virtuoso &

Cadence tool version 6.1.5 will start and two windows will pop up:

CDS.log window:

E G;;u;;u 6.1.5 - Log: /w/class. ee215u/ee215 =
File Tools Options Help CédEl‘I ce

Loading ci,cxt
Loading ams,cxt
Virtuozo Framework Licenze (111} was checked out successfully, Total checkout time was 0,07=,

EMD OF USER CUSTOMIZATION

inmouse L hl:

-0

1 =

(==
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Tool news and info window:

File Help cadence

The overwiew informstion in thisz window iz current for the IC6,1.5 releasze,
For extended informstion on bWhat's Mew in this releass, select
"Help - Hhat's Mew - In thiz Releaze" in the CIW window,

Virtuoso Design Environment What's Mew Overview in ICE,1.5
Infrastructure
* Virtuozo Performance and Memory Harning Messages

Virtuoso performance warning messzages will now ke displaged related to low
aysten memory availability and page swap activiby measurements,

*

Bindkey Editor

A rew Bindkey Editor form (replacing the Key or Mousze Binding forn) has
been introduced, This form can be selected from the CIW by choosing
Options - Bindkeys, and provides enhanced functionality to view. add.
edit. and delete application bindkey settings,

#* lezign Manazement Suystem Updates

There have been a nunber of enhancements made to the Design Manager
facilities within the Library Managzer.,

Poell

# The Pcell IDE aspplication iz now awailable in the Launch menu of WLS. VSE.

Close the tool news and info window by selecting File > Close.

Go back to the CDS.log window and start library manager (Tools > Library Manager). The following
window will pop up:

[ - — ]
Library Manager: Directory ..ss.1/ee/ee215u/ee215uta/ee215a (on ecappsi3.seas.ucla.edu) EI@IQ

Eile Edit ¥iew Design hanager Help cadence

__ Show Categories __ Show Files
Library Cell View

' 1S _8ths W igw ~| Lot
ahdlLib
analogLib
hasic
cdsDefTechLib
functional
rExamples
rLik

;r 11 -_

Messages

Log file is "Av/class. 1feefeez 15u/ees 15uta‘ee? 15a/libkanager.log”
Deleting 1 library.
Deleting lbrary ‘Oparp’.

Delete @

Now you are going to create a new library. In the library browser, select File > New > Library
and the following window will pop up:
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[y, S

Library

Mame ee215a

Directory ‘ﬁ:ezwsuf’eezwutafeezwafn & o

.

Sitemp

[ 215ascs

[ cds.lib

[ display.drf

[ libkdanager.log

[ libhdanager.log.cdslek
[ took-setup

File type: |Directories T ]

Design Manager

® Lise NOME
Use Mo D
Apply Cancel Help

Type ee215a in the name field.

Click OK.

You should now see the “Technology File for New Library”

Technology File for New Library (on eeapps03.seas.ucla.ed. SRES)
. e ————

Technology File for library "eeZ153"
You can: w Compile an ASCI technology file
 Reference existing technaology libraries I

& pttach to an existing technology library

Do not need process infarmation

m Cancel Help

Select Attach to an existing technology library option.

Click OK.

“Attach Library to Technology Library” window will pop up:

-
Attach Library to Technolegy Library (on eeapps03.seas.ucla.edu) M
— —— -

Mew Library ee215a

Technology Library

Cancel Apply Help

Select analogLib from the Technology Library menu.

4



UCLA Electrical Engineering Department EE215A

Click OK.

Next, you will see ee215a in the list of libraries in the Library Manager window.

I —— — ™
Library Manager: Directory ...s5.1/ee/ee215u/ee215uta/ee215a (on eeapps03.seas.ucla.edu) EIM

.

File Edit ‘iew Designhianager Help cadence

— Show Categories — Show Files
Library Cell View

eez15a

US_aths Wiew o | Lo
ahdlLib
analogLib
hasic
cdsDefTechLib
|
functional

rExamples |
rLib ]

Kl Im W

Messages

DeIeteJIibrary: 'Diffplair'.DeIete of library "Diffpair” succeeded.
Deletion of library done. .
Created new library "eeZ15a" at fw/class.l/eefeeZ 15u/eeZ 15uta’eez 15—

ol ™
. — —_— 4
Tutorial 1.3: Build a differential pair

In the library browser, click to select ee215a library and then click File > New > Cellview.. to
create schematic view for the new cell.

VNew File (on eeaF:psﬂi.seas.uda.ed u) u
I Fie -
Library ees13a n
Cell Diffpair
Bl | Wiew schemnat ic
Type schematic n
: Application
Open with Mﬂ
_ Abvays use this application for this type of file

Library path file
‘clazs.l/ee/ee21bu/ec21But s /ee21Ba/cdzs , ik

m Cancel Help
—_—

Type Diffpair in the Cell Name field as shown.
Click OK.

After you click OK, Virtouso Schematic Editing window will pop up.
5
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Virtuoso Schematic Editor L Editing: ee215a Diffpair schematic (on eeapps03.seas.ucla.edu) [E=gEey
Launch Eile Edit ¥iew Create Check Options Migrate Window Help cadence
- - — e - A g g @ m d
=" $ 0 @K Q@ T ¢ B-17 7KL AH ML L™ BB

- - Workspace: |Easic nl?l =9 My :ﬁ ']_[Q A T; | a§ a; n =

Havigator 78X

T Default B

Y B-

Mame
= Diffpair

Property Editor 78X

mouse L: schlingleselectPt) M ddsOpenLibhanagerd) R. s:hHiMousePopUpoJ

1(3) ‘ Command Options | Crd: Sel: 0

Important note: When you print any schematic from screenshot, remember to set the

background color to white in MS office. For example, you can set transparent color of the above window
to be white:

Wirinesas Sehierinize Fdivor | ldizinegs s 200 D sehemisite Cansceppellscasciniedu) L =Hrc &J

Launch File Edit iew Create Check Options Migrate Window Help cédence
SR F 0 @x O T ¢ R-7 v QK QL e
- - Workspace: |Basic n = [z__gjo Eiry :ﬁ l[% Ay T | IQQ Qr n -
Navigator |
¥ Default B.
Q 8-

MNama ol
= Diffpair
I
H
Property Editor
|
= 1 b
mause L: sch3ingleSelectPt] 1 ddsOpenLintanager() R: schHiMousePopUp
1(3) | Command Oplions | Cmd: Sel: 0
4
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Next, we will create simple schematic consisting of three NMOSs, two loading resistors, and a few bias
voltage sources. To create an instance, you can click Create > Instance in the Virtuoso schematic
editor or simply use shortcut key “i’. The following dialog will appear:

L& hl
Add Instance (on eeapps03.seas.ucla.edu) ‘ u
Library | Browse
b
Cell
Wiewy symbol
| "
I Mames
II M add Wire Stubs at

 all terminals & registered terminals only

Array Rows 1 Columns 1

42 Rotate Ak Sideways 2 Upside Down

Cancel Defaults

Help
e e

Click Browse to select a library component.

Another window will show up:

= — A
Library Browser - Add Instance (on eeappsﬂlsaas.utla.edum EM

— Show Categories
|| [ Library Cell View
analoglib nmos4 symbaol
LIS _gths iopamp View ~| Lock | Size
ahdlLib iprbs autdl
iprobe aulvs
basic ipulse hspicelr
cdsDefTechLib ipwl spectre
eeZ15a Ipwelf symbol
functional Isffm symbol_sxform
rExamples isin =
rLib isource
Bdmr I
mind
msline
mtline
niport
neport
naport
ndport
nhsim
nhsim4 il ] I -
njfet
nrmes
nmes4
Nmos
nnrle 31 antibe
Close Filters... Display.. Help

Choose analogLib library, nmos4 cell, symbol view. (note: while you are doing this, the Add
instance window is getting updated as well).

Click Close and point your mouse cursor over the Virtuoso editing window.

Left click to place the instance into a desired location. As you move the mouse away, you will see a
contour for another instance (shown in yellow); press ‘Esc’ key to exit from Add Instance mode and the
yellow symbol will disappear.
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Virtuoso Schematic Editor L Editing: ee215a Diffpair schematic (on eeapps03.seas.ucla.edu) [E=SEER—
Launch File Edit View Create Check Options Migrate Window Help cadence
. = — = O ——
U @A P00 @EXQETLE e L7 7| LLEBE |
- - ‘Workspace: |Basic ' ==, My :ﬁ by Ay T ‘ B [ B-

Navigator 78X
Default B. W
Q B-

= Diffpair
@) MO (nmosd)

Property Editor T e X

o - "l . . . . . . . . . . il
mouse L: schSingleSelactPi) M: schHIObjectPropery() R: schHitMousePopUp()
1@ > | cmd: sl 0 i

Now, add instance of another NMOS device (press “1°) and click Sideways,

Add Instance (on eeappsl}lseas.ucla.ed\.l)‘

S

Likrary

Cell =t
Wiew =ymbol
Mames

Erowse

& Add Wire Stubs at

— all terminals @& registerad terminals only

Source difusion area

Drain diffusion area

Source diffusion periphery
Drain diffusion periphery
Drain diffusion res squares
Source difusion res squares
Drain diffusion length
Source diffusion length
Multiplier

Temp rise from ambient

Array Rows 1 Columns 1
47 Rotate Ak Sideways = Upside Down =
kdodel name
Width
Length

€Y cencel
—

Defaults || _Help

Place it to the desired location.
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Property Editor zax .

mouse L: schiingleSeleciF)
1(3)| >

M: schHiCreatelnst()

R: schHilouseFopUp()

Virtuoso Schematic Editor L Editing: ee215a Diffpair schematic (on eeapps03.seas.ucla.edu) =
Launch File Edit ¥iew Create Check Options NMigrate Window Help cadence ‘
0 mxXOBHE ¢ R-TrIQAQAAHE P L 1L+
Warkspace: Basic n ‘?‘ @3 '% :Iﬁ 'LQ 'ﬁ 'lh ‘ Bh Q- n -
Mame P
I Diffpair
(@) MO (nmosa)
Q) M1 (nmosd)

| cmet: Sel: 0

Now we can adjust the size of the transistors by editing instance properties. Left click on the NMOS to
select the component. Then, press ‘g’ to modify its properties. Set Model name to nch (pch for PMOS),
Width to 26um, Length to 180nm, S/D diffusion area to 1.56e-11 and periphery to 53.2u

(calculation provided in handout).

Browse Reset Instance Labels Display

Fropery Yalue Display

Library Mame analoglib off n

Cell Mame nnosd o n

View MName sunbal o K3
Instance Mame MO off n

Add | Delete | Madify

CDF Parameter Walue Dizplay

Model name rich off n
With 260 M of 9
Length 180n M LA -
Source difusion area 1.56e-11 off n
Drain diffusion area 1,568-11 off n
Source diffusion periphery 53.2u M off n
Drain diffusion periphery 53,20 M ,Uﬁ n
Drrain diffusion res sguares off n
Source difusion res sguares off n
Mrain_ difflisinn [gnnth m off - |

B _Cancel ,|_&pply )| Defaults || Previous || Mext || He_lp )

r “
Edit C'kject Properties (on ecapps03.seas.ucla.edu) [&J
R —

&pply To anly current n instance n M

Show _ system o user ¥ CDF
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Click OK and repeat this for another NMOS. Add one more NMOS as the tail current source and set the

W/L to 14um/180nm.

Next, add loading resistor to the schematic (cell res from analogLib library), then instantiate DC
voltage source (cell vdc from analogLib library) to bias the transistors. After that, add two sine waves
as the differential inputs (cell vsin from analogLib) . Set Amplitude to ImV, Initial phase
to 0 and Frequency to 1IMHz. The other sine wave has the same amplitude and frequency but with an

initial phase of 180.

Edit Object Properties (on eeappsl]g.seas.ucla.edu_

The schematic should look like this (use Create > Wire menu or simply press ‘w” key to enter wiring

mode / ‘Esc’ to exit):

Erowse

Reset Instance Labels Display

Property
Library Marme
Cell Marme
Wiew MName

Instance Mame

User Property

lwslgnore

CDOF Parameter
First frequency name
Second frequency name

Moise file name

Mumber of noiseffreg pairs

DC woltage

AC magnitude
AC phase

HF magnitude
FAC magnitude
PAC phase
Delay time
Offset voltage
Amplitude
Initial phase for Sinusoid
Frequency

amplitude 2

Initial nhase for Sinnsnid 2

m Cancel . Apply

Walue
analoglib
vzin
=ymbol
W0
A Delete Iodify
kaster Walue Local Walue
TELE
Walue

o]

Im ¥

0

1M Hz

Defaults Frevious
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=

=%

=+

abkb

Display
ff

-
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=
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Help
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e N T N

COC)

Electrical Engineering Department EE215A



UCLA

EE215A

Electrical Engineering Department

% WE00kIE B (&

Havigator 78X

B

Virtuoso Analog Design Environment =AEEAL X
Launch File Edit Miew Create Check Opfions Migrate Window Help cédence
U e & d 0@ x @ T ¢ 8-17 v IQ QAT L LXeE

- - Workspace: | ADE L ‘ = & My :lﬁ Ly i T; | =y || & ‘ -

Default

Q

Mame

RO (res)
R1 (res)
WO (wsiny
W1 (wsiny
WE (wdc)
W3 (wdc)
W4 (vdc)
WO (vdc)
netz
netd
netld
nets
netns

N N7 E) 6) 8) B) B) B) B)

MZ (nmosd)

Property Editor 78 %

"

ol

1(3) | Zoom Out

| imouse L: sch3ingleSelectPi)

M: schHiDelete() R: schHiMousePopUpi) "

| Cmd: Sel: 0 Status: Ready | T=27 C \ Simulator: spectre

It is a good practice to periodically save your work by clicking on Check and Save button. You can
also save your work from the drop-down menu Fille > Save (or File > Check and Save).

Invoke simulation environment by choosing Launch > ADE L from the Virtuoso schematic editor
window. Note: If you are asked to check the license for “Analog_Design_Environment_XL”, choose Yes

or Always. The Analog Design Environment window will pop up:

r = 5
3, Virtuoso Analog Design Environment (1) - ea215a Diffpair schematic (on eeapps03.seas.ucla.edu) = | B i
Launch Session Setup  Analyses Yariables Owtputs  Simulation Besults Tools Help (éden(e

] _— oo )
..lg-*.{-;’-'|lC27 |F‘55J}"|3g‘
7E X -
Design Yariables gnalyses | sac
Type | Enahle| Arguments | ===
ame | Walug | @
= ()
=
¥
Outputs 25 x| O I
Mamme/signal/Expr | Walue | Plot| Save| Sawve Options |
L]
[
. Plot after simulation: |Auto n Plotting mode: Replace n
mouse L: hd: Rl
2y | Delete | Status: Ready | 7=27 ¢ | Simulator: spectre [}
=

The first step is to setup simulation environment, including models, input sources, type of analysis etc.
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Setup > Model Libraries and setthe Model Library File to 215a.scs inside the ee215a folder and
set Section to mos as shown below.

i o s on s NI
|
|Model File |Section |
- Global Model Files
i Wt Muiiclags 1 /ee/eeZ1 SufeeZ] SutaleeZ15a/21 50508 mos
i _|=Click here to add model fila= - I
e
A
!
#
-
@ cencel spply Help

Click OK and go to Anallyses > Choose, following entry form will show up.

|-~ T —— il
Choosing Analyses -- Virtuoso Analog Design Environment (1} {on... u
- — T —— S——

Analysis & fran W dc s 8C w hoise |
oo w sens o domatch o sth
W P2 WA 5P w envip e P55 '
w pac w psth o opnoise o pef
— psp  OpsE o gpac  gpnoise
e st w gpsp o hhb  hbac
'« hbnoise

Transient &nalysis

Stop Time 100

Accuracy Defaults (errpreset)

_ conservative _ moderate __ liberal

— Transient Noise

__ Dynamic Parameter

Enabled Ciptions...
—= _

Cancel | Defaults | apply | H

Specify the Stop Time to 10u and click OK.

Your Analog Design Environment window should now look like this:
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. Virtuoso Analog Design Environment (1) - ee215a Diffpair schematic (on eeapps06.seas.ucla.edu) 51#

Launch Session Setup  Analyses  Mariables Outputs  Simulation  Besults Tools Help

cadence

=N SCERER N=N" =

A

Analyses
Design Yariahles Y
Type | Enable| Arguments
Mame | Value | || tran v 010U
Outputs

(ZIEx] (= Metlist and Run

Mame/Signal/Expr | Walue | Plot | Save|

Save Options

nmouse L: I

= Results in ../ee/ee?] Su/eez Sutassimul:| | P10t after simulation: M Platting mUd&M

R

2(4) | Metlist and Run | Status: Ready | T=27 | Simulator: spectre | State: spectre_statel

Start the simulation by clicking on “Netlist and Run”. Then the output log window pops up:

rfwﬂdass.lfee}’eeZlSufeeZ

File Help

cadence

tempeffects = all
errpreset = mnoderate
method = traponly
lteratio = 3,5
relref = sigglobal
cmin = 0 F

Zmin 1 ps

tran: time = 2838 n= (2,84 X}, step = 83,33 n=
tran: time = 7E3.8 n= (7,84 XY, step = 83,33 n=
tran: time = 1,284 us (12,8 %), step = 83,33 n=
tran: time = 1,784 us (17,8 X, step = 83,33 n=
tran: time = 2,284 us (22,8 X}, step = 83,33 n=
tran: time = 2,784 us (27,8 X}, step = 83,33 n=
tran: time = 3,284 us (32,8 X}, step = 83,33 n=
tran: time = 3,784 us (37,8 X}, step = 83,33 n=
tran: time = 4,284 us (42,8 X}, step = 83,33 n=
tran: time = 4,784 us 47,8 X, step = 83,33 n=
tran: time = 5,284 us (52,8 X}, step = 83,33 n=
tran: time = 5,784 us (57,8 X}, step = 83,33 n=
tran: time = 6,284 us (62,8 %), step = 83,33 n=
tran: time = 6,784 us 67,8 H). step = 82,33 n=
tran: time = 7,284 us (72,8 X}, step = 83,33 n=
tran: time = 7,784 us (77,8 ). step = B3.33 n=
tran: time = 8,284 us (82,8 X). step = 83,33 n=
tran: time = 8,784 us (87,8 X}, step = 83,33 n=
tran: time = 9,284 us (92,8 %), step = 83,33 n=
tran: time = 9,784 us (97,8 X}, step = 83,33 n=

Humber of accepted tran stepz = 123

Motice from spectre during tranzient analysis “tran',
Trapezoidal ringing iz detected during tran analysis,

(833
(833
(833
(833
(833
(833
(833
(833
(833
(833
(833
(833
(833
(BE2
(833
(833
(833
(833
(833
(833

e
e
e
e
e
e
e
e
e
e
e
e
e
e
e
e
e
e
e
e

Fleaze uze method=trap for better resultz and performance,

Initial condition solution time: CPU =
Intrinzic tran analysis time: CPU =
Time accunulated: CPU = 178,972 ms. elapsed = 559,19% ns,
Peak resident memory used = 28,9 Mogytes,

finalTimelF: writing operating point information to rawfile,

modelParanster writing model parameter wvalues to rawfile,
element: writing instance paramster wvalues to rawfile,

outputParamster: writing output paramster wvalues to rawfile,

dezignParanyals: writing netlist parameters to rawfile,
primitives: writing primitives to rawfile,
subckts: writing subcircuits to rawfile,

0 =, elapsed = 727,177 u=,
12,998 ns, elapsed = 15,6529 ns
Total time required for tran analyszis “tran': CPU = 12,997 mns. elapsed

5
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After simulation is done, go to Results > Direct Plot > Main Form. There are three pop-up
windows: What’s New in Virtuoso Visualization and Analysis XL, Direct Plot Form, Virtuoso(R)
visualization & Analysis XL. The Direct Plot Form pop-up window looks like this:

S)

Direct Plot Form (on eeapps06.seas.ucla.edu)
Plotiing Mode | Append ﬂ
Analysis
& fran
Function
& ‘oltage — Current
— Power — Moise Measurement
— PLL Moise PSD

Select Net B

et
Differential Mets

Prepenc Instance with £ Terminals petory

&dd To Outputs —

= Select Met on schematic...

m _Zancel

_Help

2

Select Differential Nests to plot the one net in reference to another one.

Go to schematic, click the two input nets and then two output nets, the corresponding voltage waveforms
are plotted in the “Virtuoso(R) and Visualization & Analysis XL window:

V1 ee215a Diffpair schematic £

Virtuose (R) Visualization & Analysis XL (on eeapps06.seas.ucla.edu) ' - - =ren X
File Edit Miew Graph Axis Trace Marker Measurements Tools Window Browser Help cadence
) o I ® |Layout Auto nSubwmdnws ient Respnnsen Workspace: | Classic n S ﬁ#)
B Q Q » Data Point

AN L LN\ - U

Transient Response

time (us)

mause L:
a7y | Create Marker
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To change the background color, goto Graph > Properties, the following window shows up:

Graph Properties (on esappsl6.seas.ucla.ed =k

General Strips Graph Cptions

Graph Title = Transient Response  Default

User Title ~
Title Fonta | He|yetica

Color « |l Background __ Use Gradient

Clozse Apply

Change the color to white and click OK. The “Virtuoso(R) and Visualization & Analysis
XL”” window now looks like this:

:

File Edit Wiew Graph Axiz Trace Marker Measurements Tools Window Browser Help cadence '
) P ] % |Layout|eute nsubwindows:iemResponsen |[warkspace: | Classic na (o

A A
19 © & & & M »l@ @ pmron B B AW ey B e B

|| K] eeZi5a Diffpair schematic [

Transient Response
Mame ! ” s
— L
I i W ...netS /net7y; tran ( SD'Di
~ I ..net3 Metd); tran {
zZoo H
10.0 o
=
=00 o
=
-10.0 4
-20.0 4
_SD‘D_|\ — T T T T T T T T T T T T T T T T T T | T T T T T T T T T T
0.0 25 5.0 7.5 10
time [us)
nmause L: Il: R:

3(7) | plat nesw graph subwindow [l

Now you are able to monitor more voltage and current waveforms at other nodes and can build circuit on
your own.
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